Опасная уязвимость в UNIX/Linux-среде KDE

Ошибка позволяет перехватить управление системой, использующей . Серьезная обнаружена в популярном программном обеспечении с открытым исходным кодом KDE. Ошибка, расцениваемая аналитической фирмой FrSIRT как «критическая», позволяет удаленному злоумышленнику получить контроль над уязвимой системой. KDE это пакет ПО рабочего стола для - и -систем, куда входит - и другие приложения.

Ошибка находится в механизме интерпретатора JavaScript, которым пользуется Konqueror и другие компоненты KDE, утверждается в опубликованном в предупреждении. Чтобы воспользоваться уязвимостью, злоумышленник может сформировать специальную последовательность URI в коде . В предупреждении FrSIRT говорится, что для того, чтобы атака достигла своей цели, атакуемого компьютера должен посетить веб-страницу злоумышленника посредством Konqueror.

Ошибка присутствует в KDE 3.2.0 и выше, включая KDE 3.5.0. Исправления уже вышли и доступны для скачивания на kde.org.